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OVERVIEW


A.  Contact details and installation of the PRIMER v6 software 


For any up-to-date news about PRIMER, including details of upcoming PRIMER workshops, see our web site at: http://www.primer-e.com

Please report any bugs, technical problems, dislikes or suggestions for improvement to Ray Gorley at: tech@primer-e.com 

For licensing and other general enquiries, contact Cathy Clarke at: admin@primer-e.com

Use this latter e-mail address to contact Bob Clarke, for queries related to the scientific methods. 

Our business postal address is:

PRIMER-E Ltd

3 Meadow View
Lutton
Ivybridge PL21 9RH
United Kingdom

Tel: +44 (0)1752 837121
Fax: +44 (0)1752 837721

(or you may, if you prefer, use the registered address of the company:  PRIMER-E Ltd, Plymouth Marine Laboratory, Prospect Place, West Hoe, Plymouth PL1 3DH, United Kingdom)


PC with Intel compatible processor

Windows 2000/XP/Vista/7 or later, 32bit and 64 bit.
Memory. For Windows 2000 and XP: 128 Mb (256 Mb recommended). For Windows Vista or later: 512Mb (1Gb recommended). 
Internet Explorer 5.01 or later is needed to install the .Net environment

To be able to read and write Excel worksheets you need Excel 2000, or later, installed on the PC.

This is a stand-alone product for installation on an individual PC, not a network server.  You need to be logged on as an Administrator.
Insert the PRIMER CD in your CD drive.  The install program will automatically run unless you have disabled AutoPlay on your drive.  (If it does not run open Windows Explorer, right click on the CD drive and select the ‘Install’ or ‘AutoPlay’ option.) The install program may install or update the .Net framework on your computer first. You will be asked for your serial number and key which is on the front of the CD case.  It is advisable to close down all other programs before commencing installation.

General information about the techniques underlying the analyses are found in the accompanying Methods manual: ‘Change in Marine Communities’, by Clarke, Warwick, Somerfield and Gorley (2005). Information specific to PRIMER 6 is contained in a User manual/Tutorial and the software Help system.  The latter is context sensitive: if you click on the Help button in a dialog then you will get an appropriate help topic. You can also get into the help system by choosing the Help>Contents menu option or clicking on the help button on the button bar. You can then browse this system via the Contents or Index tabs in the Help window. If you are still having problems, contact the staff at PRIMER-E (see the top of this page), who will be happy to help.

B. Introduction to the methods of PRIMER 


PRIMER 6 (Plymouth Routines In Multivariate Ecological Research) consists primarily of a wide range of univariate, graphical and multivariate routines for analysing arrays of species-by-samples data from community ecology.  Data are typically of abundance, biomass, % cover, presence/ absence etc, and arise in biological monitoring of environmental impact and more fundamental studies, e.g. of dietary composition.  Also catered for are matrices of physical values and chemical concentrations, which are analysed in their own right or in parallel with biological assemblage data,  ‘explaining’ community structure by physico-chemical conditions.  The methods of this package make few, if any, assumptions about the form of the data ('non-metric' ordination and permutation tests are fundamental to the approach) and concentrate on approaches that are straightforward to understand and explain. This robustness makes them widely applicable, leading to greater confidence in interpretation, and the transparency possibly explains why they have been adopted worldwide, particularly in marine science but increasingly in terrestrial, freshwater, paleontology etc contexts. The statistical methods underlying the software are explained in non-mathematical terms in the associated ‘methods’ manual (Clarke et al 2005), which also shows outcomes from many literature studies, e.g. of environmental effects of oil spills, drilling mud disposal and sewage pollution on soft-sediment benthic assemblages, disturbance or climatic effects on coral reef composition or fish communities, more fundamental biodiversity and community ecology patterns, mesocosm studies with multi-species outcomes etc. Many of these full data sets are included with the package so that the user can replicate the analyses given in the manual.  

Though the analysis requirements for biological assemblage data are a principal focus, the package is equally applicable (and increasingly being applied) to other data structures which are either multivariate or can be treated as such.  These include: multiple biomarkers in ecotoxicology, and their relation to water or tissue concentrations of chemical contaminants; composition of substrate in geology or materials science; morphometric measurements in taxonomic discrimination; genetic studies, involving presence or absence of specific sets of alleles; signals at multiple wavelengths in remote sensing, characterising vegetation or water masses, etc.  Univariate measurements which can sometimes be treated more effectively in multivariate fashion include particle size analysis for water or sediment samples and size frequency distributions of organisms in cohort studies (the multivariate variables are the discrete particle or organism size classes).  Sets of growth curves for individual organisms, monitored through time (‘repeated measures’) are also readily analysed:  the unifying feature is that all data sets are reduced to an appropriate triangular matrix representing the (dis)similarity of every pair of samples, in terms of their assemblages, suites of biomarkers, particle size distributions, shape of growth curves, etc.  Clustering and ordination techniques are then able to represent the relationships between the samples, and permutation tests impose a necessary hypothesis testing structure.  To demonstrate the range of application areas, references to ISI-listed publications which cite earlier versions of the PRIMER methods manual (and one of the core methods papers, Clarke 1993) can be download from the PRIMER-E website (www.primer-e.com). 


The basic routines of the package cover: hierarchical clustering into sample (or species) groups (CLUSTER); ordination by non-metric multidimensional scaling (MDS) and principal components (PCA) to summarise patterns in species composition and environmental variables; permutation-based hypothesis testing (ANOSIM), an analogue of univariate ANOVA which tests for differences between groups of (multivariate) samples from different times, locations, experimental treatments etc; identifying the species primarily providing the discrimination between two observed sample clusters (SIMPER); the linking of multivariate biotic patterns to suites of environmental variables or other biotic arrays (BEST and LINKTREE); comparative (Mantel-type) tests on similarity matrices (RELATE); a second-stage MDS routine in which relationships between a large set of ordinations can be visualised (2STAGE); standard diversity indices; dominance plots; geometric abundance distributions; species accumulation estimators; aggregation of arrays to allow data analysis at higher taxonomic levels, etc.  A further unique feature of PRIMER is the ability to calculate and test biodiversity indices based on the taxonomic distinctness of the species making up a quantitative sample or species list, indices whose statistical properties are robust to varying richness.  These permit testing for change in biodiversity (TAXDTEST), by comparison with a regional ‘species pool’, so that diversity patterns over wide space/time scales are comparable when sampling effort is uncontrolled .

C. Changes from PRIMER 5 to PRIMER 6  


1) Moved entirely into the new Microsoft .NET environment, giving the software a fully modern Windows appearance, safeguarding future growth paths and opening the way to diversification onto different platforms (UNIX, Mac) in future. (Currently v6 is only available in a Windows environment, though this could be a Virtual Windows environment on a Mac, for example). 

2) Replacement of inefficient and inflexible graphics and grid controls (e.g. Graphics Server), by native code in .NET, has greatly improved ‘look and feel’ of the graphics, which are now fully tailored to the needs.  This has also cut through speed bottlenecks in handling large spreadsheets.  

3) No fixed size constraints on data matrices or group sizes for any analysis.  The limitations are imposed only by total available RAM.  Windows 2000 or later, and 256Mb RAM, recommended.  No longer possible to run on Windows 95.

4) Speed gains of around a factor of 5 in most of the heavily-computational algorithms (MDS, BIO-ENV searches, permutation tests etc); larger speed gains in manipulating data windows, especially for very large data sets (e.g. opening and closing factor windows).  

5) Now fully multi-tasking.  You can start several very long analyses and continue doing other things in the workspace. This takes full advantage of multi-processor systems (different tasks will automatically be allocated to the least loaded processor).


6) The workspace now displays an ‘Explorer tree’ which can be navigated to recall instantly any of the derived worksheets, plots or results windows.   This is not solely a display: the tree structure is used internally to pass information between related data sheets or plots (e.g. new factors defined from a CLUSTER dendrogram are back-propagated through the similarity matrix to the original data matrix, and forward-propagated to an existing MDS plot from that same similarity sheet). Results windows are now local to each analysis, making it easier to find results at a later stage. 

7) Workspaces are now saveable in their entirety;  PRIMER v6 can be shut down and re-opened at a later date, recalling the workspace content in exactly the form it was left (i.e. irrespective of any subsequent changes or deletions to the data files that were originally read-in to the workspace).

8) Improved data entry dialog and wider selection of input formats.  Rectangular Excel sheets of variables by samples (or samples by variables) are read in easily using a new entry ‘Wizard’, which now allows choice of sheet within the Excel file by name.  PRIMER does not have the Excel constraint to 255 columns.  Larger files can be read-in from multiple Excel sheets and Merged or, if created by a database package in three-column format (‘sample number, variable number, value’), can now be read directly into PRIMER – and will be automatically converted to rectangular format.   

9) There is now label matching: samples or variables do not need to appear in the same order for those analyses that match two different sheets (e.g. BIO-ENV, RELATE, ABC dominance plots, Aggregation etc).  You usually only need to worry about the selection in the active worksheet and v6 will perform any selection or re-ordering needed for other sheets.  One major advantage of label matching is the automatic merging of  two species-by-samples sheets in which species lists are only partly overlapping (and in a different order).  Consistent spelling of labels is required, naturally!

10) Worksheets are given an explicit data type (abundance, biomass, environment, other), which permit sensible defaults and warnings (e.g. if ABC inputs are not of types abundance and biomass).   

11) New data handling operations include: ranking of variables (e.g. an alternative to individually transform​ing environmental variables); sorting (by name or factor levels) and moving data; more powerful individual transform options, that can now combine different samples, variables, numeric factors and indicators, as well as other worksheets (using the new label matching); more extensive checks on input data (including validation of aggregation files); and a new Sum tool. 

12) Improved output formats, and a wider range of options.  Tables in the results windows are formatted to be able to copy and paste directly into Excel spreadsheets.  Many routines will now allow summary information to be sent to a new worksheet (for further operation or export) instead of to text-format results.  There is a multiple-page print option, useful for large dendrograms, and additional graphics output formats, including .jpg, .tif, .png.  The standard vector format is the Windows enhanced metafile (.emf).  Final point co-ordinates (e.g. of the new position of samples after rotation of an MDS plot) can also be output. 

13) Data sheets now permit factors on the samples (or indicators on the variables) to be read in from (or saved to) the Excel or text formats, allowing rapid transfer of all information between formats.  Factors are now easily imported from other data sheets, combined to produce composite levels (e.g. a site-by-time composite factor could be used to Average or Sum over replicates for each site/time level), and levels can be given default symbols and colours for use in all plots.

14) Improved timer, showing how long a particular analysis has left to run, plus a Stop button, so that any analysis which threatens to take too long to execute can be swiftly and cleanly terminated.

15) In ordination plots (MDS, PCA), more flexible addition of symbols and labels denoting (different) factors.  The 3-d plotting routine is greatly improved, both in respect of rotation of axes (and points, for MDS) and reflection of axes, with the ability to add labels to points in addition to symbols. Information displayed on plots is more comprehensive, with the automatic use of subtitles and a ‘history box’ to allow clear differentiation between plots from different transform and similarity options, and a key for bubble size is given when a variable is superimposed.

16) In clustering, keyed symbols can now be added (independently of labels) to dendrograms, and the latter can be displayed in any one of four orientations.  Clusters produced at a fixed similarity level can be identified and saved as a factor, and can then be displayed on the matching MDS.  Alternatively, an MDS plot can show the results of a cluster analysis as smoothed convex contours, drawn round points that are clustered at several specified resemblance levels.

17) Points in an ordination (in 2- or 3-d) can be joined by straight line segments, in a defined order, allowing trends in time, space or environmental gradient to be more readily seen.  

18) MDS diagnostics are improved: Shephard plots of distances in the ordination against original dissimilarities are given for both 2- and 3-d solutions; % contributions of individual points to the stress level are listed; an alternative fitting scheme allows a different treatment of tied similarities, and the user has more control over the precision of output stress values.

19) In PCA, vector plots are now permitted (since the axes are linear combinations of the variables) and any pair or triple of PCs can be plotted in the 2- or 3-d configurations.

20) Dominance plots from a single sheet (abundance or biomass) can have the multiple lines identified as different levels of a factor (by differing line colours and/or symbols). For ABC curves, the full set of plots from all samples are now automatically created in one run of the routine.  The (confusing) option in v5 of automatic summation of selected samples has been removed (if needed, it can be carried out using the new Sum tool prior to entering Dominance or Geometric plot menu). 

21) The ‘funnel’ and ‘ellipse’ plots for average (and variance in) taxonomic distinctness indices are also enhanced, with more flexible choice of labels and symbols, colour shading etc 

22) Perhaps the most useful enhancement is the ability to zoom in on the content of any portion of a plot (ordination, dendrogram, funnel plot, draftsman plot etc), whilst retaining axes and scales, and having the ability to scroll through the plot at the current magnification.  This even extends to changing the aspect ratio (though not for ordinations!), by first drawing a rectangle around the portion to magnify.  This is particularly useful for dendrograms, which for large numbers of points need to magnify the sample scale but not the similarity scale.  

23) For MDS ordinations, interest is usually less in magnifying a subset of the plot than repeating the ordination just for that subset of points:  again, drawing a box around the subset on the plot allows a re-run of the MDS for those points, with a single click on a menu/toolbar icon!

24) Pre-treatment operations are greatly expanded: a) standardisation options are now by species or variable, and by total or maximum; b) a cumulate operation assists in widening the application of these routines to size classes in particle or body-size distributions; c) variables can be weighted, e.g. downweighting some species on the basis of misidentification rates. Overall transformation and normalisation options remain as in v5 but, importantly, all pre-treatments now become an initial step, separated from similarity calculations, allowing a highly flexible range of alternatives.  

25) The new user is still guided to ‘safe’, standard choices (e.g. Bray-Curtis on transformed species abundances, normalised Euclidean distance for environmental variables), but the more experienced user now has access to nearly 50 similarity/dissimilarity/distance measures, drawn from different literature contexts, and collectively referred to as ‘resemblance measures’.

26) New research techniques here are: a) ‘dispersion weighting’, the downweighting of individual species counts using their innate heterogeneity in replicates, arising from clustered spatio-temporal distributions; b) ‘taxonomic dissimilarities’, extending the concepts of taxonomic distinctness introduced in PRIMER v5 from diversity measures to dissimilarity coefficients.

27) Missing values are now tolerated in some routines and, where they are sparse, can be assumed ‘missing at random’, many fewer variables than samples are selected, and the variables can be transformed to approximate normality (e.g. environmental-type variables), an EM (Expectation-Maximisation) algorithm for optimal prediction of missing data is provided.  (Use with care!) 

28) Data handling operations such as transforming and ranking now apply to resemblance matrices, which allows conversion of correlation matrices to similarities, e.g. to obtain environmental variable MDS plots. Similarities can be explicitly switched to dissimilarities, and vice-versa, and another resemblance tool is a ‘Model matrix’, for building model matrices in RELATE tests (non-parametric Mantel-type): these might represent serial or cyclic trends with replication of groups. 

29) The similarity percentages routine (SIMPER), identifying variables that contribute most to the difference between two groups, is expanded to cover two-factor designs and to apply to Euclidean distance (e.g. for environmental variables) as well as Bray-Curtis. Other menu items are regrouped: BIO-ENV and BVSTEP are merged (into BEST) and ANOSIM2 absorbed into the ANOSIM menu; all global permutation tests now create histograms of null distributions.

30) Several new global significance tests are provided (robust, non-parametric, permutation-based and exact), to test for presence of meaningful structure before interpreting results and displays: 

a) DOMDIS, which computes distances between the curves in dominance plots, which can then be input to an ANOSIM test of a priori group structure; 

b) a BIO-ENV test, which allows for the bias inherent in optimal selection of a subset of variables from one matrix (e.g. environmental) that best ‘explains’ the pattern in a second (e.g. species); 

c) the SIMPROF (similarity profile) routine, which tests for evidence of structure in an a priori unstructured set of samples.  In combination with clustering and a new facility to condense specific substructures in dendrograms (by clicking on vertical lines), this can generate trees that are pruned to objectively-defined groups.  A factor defining these groups can be automatically created. 

31) LINKTREE, a new routine to link biotic patterns to environmental variables (or similar linkage problems).  Linkage trees – a non-parametric version of multivariate regression trees or CARTs – optimise successive binary divisions of biotic patterns using threshold values of environmental variables, and aim to provide piecemeal ‘explanations’ of assemblage groupings in terms of single environmental variables.  It is effective in conjunction with the BIO-ENV (BEST) routine, or may provide better explanations where BIO-ENV fails because forcing variables are very non-additive.  It can be combined with SIMPROF, to test for the ‘significant’ structure requiring explanation.

32)  Species-accumulation plots now calculate and plot a wide range of richness estimators (Chao 1&2, Jacknife 1&2, Bootstrap, Michaelis-Menten, UGE) as samples are cumulated in original, specified or permuted orders.  Results are sent to a worksheet for easy export.

33) A unique feature of v5 was the calculation of taxonomic distinctness measures of biodiversity, based on taxonomic or phylogenetic relatedness of species in a sample, and testing for ‘biodiversity loss’ by simulating selection from a master species list (TAXDTEST).  v6 enhances this not only by better graphics but by the ability to use a different master list for the simulation than the sample data (e.g. fossil lists can now be compared with modern ones), and the option to specify a data sheet that determines the frequency with which each species is drawn from the master species list, when constructing the ‘null model’ simulations.
D. Typographic conventions


Text in bold indicates the menu items that need to be selected, 

> denotes cascading sub-menu items, tab choices, dialog boxes or sub-boxes,

( denotes a button entry in a dialog box (so-called ‘radio buttons’ – only one can be selected),

( indicates a tick in the specified box (so called ‘check boxes’ – either on or off),

 text inside a cartouche is an instruction to select the suggested entry (e.g. filename) or actually to type it in, and

(  ) & (  ) & (  ) indicate several steps that need to be carried out in the one box, where brackets are used naturally to split up the different components of the dialog.

For example, 

Analyse>Resemblance>(Analyse between(Samples) & (Measure(Bray-Curtis similarity) & ((Add dummy variable>Value: 1)

is an instruction to select the main menu item Analyse, the sub-menu item Resemblance, and analyse between samples using Bray-Curtis similarity, adding a dummy species with value 1 for all samples, prior to computing similarities (this is a modification to the Bray-Curtis coefficient to force it to behave in a particular way as the samples become very sparse – see the Methods manual for further discussion of the effect of this adjustment). The dialog this corresponds to is:


E. A brief tour through the operation of PRIMER v6


 The first step is to get data into PRIMER.  Data is held in worksheets;  you can read in data files in several formats, or you can enter and edit data directly.  The PRIMER CD contains a number of example data files: if necessary, copy the Examples v6 directory from the CD to your hard drive. (If you installed to the default location you should find the Examples v6 directory already under C:\Program Files\PRIMER-E\PRIMER 6\Examples v6.)  To read in data, select File>Open from the main menu and navigate to, for example, the Examples v6\Ekofisk subdirectory, selecting the ekma.pri file.  This is of marine species assemblages at sites round an oilfield drilling rig (see the description box from Edit>Properties). The data can be input either as samples (rows) by variables (columns), which is the convention in statistics, or as variables by samples, the convention for biological matrices, but PRIMER does need to know which are the samples and which the variables!  Check this from the Edit>Properties menu where (Samples as(Columns) is the correct choice here.  


As well as its own v6 format (.pri extension), PRIMER can directly read in text files, Excel files and the old PRIMER data formats. Check the environmental data file for Ekofisk, in Ekofisk\ ekev.xls, by opening it in Excel, to see the rectangular format that PRIMER expects.  Note that it happens to be transposed (samples by variables) compared with the species matrix.  The entries must be numeric, though row and column labels can be alphanumeric.  The sample labels are unique and match those for the biological data, which will allow comparison of the two arrays, though the samples need not be in the same order in the two matrices (a change from v5).  Larger matrices than can be handled by Excel in rectangular format (i.e. >255 columns), can be read in as 3-column text files (‘sample label, variable label, value’ on each line, with tab, comma or other specified separator), or smaller sub-matrices read in separately and merged in PRIMER. 

Select File>Open from the menus. You can select the file types to read using the box at the bottom of the dialog.  The default setting will read PRIMER 5 (and PRIMER 4) files as well as the new PRIMER 6 format, but you have to select the Excel option to display the *.xls files.  Go through the steps in reading in this particular Excel file, by File>Open>(File name: ekev.xls) & (Files of type: Excel files (*.xls))>Open, then in the Excel File Wizard take all the defaults except (Orientation(Samples as rows) & (Data type(Environmental) on the second dialog box. 


To input data directly into PRIMER choose File>New.  For worksheet type choose (Sample data and in the Sample Data Properties dialog set the number of data rows and columns. You can specify whether the rows or the columns represents samples, and optionally specify the type of data (e.g. Data type(Abundance), which simply allows v6 to choose natural defaults.  Add meaningful (and unique) sample and variable labels using, for example Edit>Labels>Samples.  Save the sheet using File>Save Data As and save frequently as you edit.  The default file type is a binary PRIMER 6 worksheet format (.pri), which is not backwards compatible (i.e. cannot be read by PRIMER v5, though v5 .pri files can be read by v6).  You can also save the data in Excel format.


Some analyses require prior identification of the samples into groups, e.g. different sites, times, treatments etc.  This information is held with the worksheet in the form of one or more factors (e.g. time) with different levels (e.g. Jan, Feb, Mar, …).  You can create or modify this information by the Edit>Factors menu, when the active worksheet is the data matrix.  Similarly, grouping structures on the variables are created using Edit>Indicators.  Note that you can get the items on the Edit menu by right-clicking with the mouse when the cursor is over the worksheet. 

Use Edit>Factors to look at the factor ‘Dist’ already set up for the ekma.pri  worksheet.  This groups the samples into one of four classes, depending on how close they are to the centre of drilling activity.  Then revert back to the data worksheet by Cancel or OK.  (The four levels, A to D, are defined in the Description box under Edit>Properties).


Pre-treatment of the data (sometimes in more than one way) is usually desirable.  For assemblage data, transformations will reduce the dominant contribution of abundant species to Bray-Curtis similarities.  Though not usually needed for controlled (‘quantitative’) sampling, standardising of samples to relative composition (so sample totals are all 100%) can be achieved by Analyse>Pre-treatment>Standardise>(Standardise(Samples)&(By(Total). Transformation of all values (which should be after standardisation, if the latter is appropriate) is achieved by, for example, Analyse> Pre-treatment>Transform (overall)>Transformation: Square root. For environmental-type data, such as contaminant concentrations, it may be appropriate to transform to approximately normal distributions (to justify the use of a Euclidean distance measure), and then to normalise (a location and scale change) to place different types of variables onto a common measurement scale.  See the Methods manual for the rationale for various choices. Other pre-treatment options include differential weighting of each variable (via supplied weights or by calculating dispersion properties of replicates).  Each pre-treatment operation creates a new worksheet of transformed/standardised/ normalised data, and sometimes the option to send summary statistics to a new worksheet (e.g. the mean and standard deviation for each variable, when taking Analyse>Pre-treatment>Normalise).


‘Resemblance’ is the general term covering similarity, dissimilarity or distance coefficients.  You can create a resemblance matrix with the Analyse>Resemblance menu item.  Similarity matrices can be saved as individual PRIMER format files (they will be given a .sid extension, as in v5), but this is rarely necessary in v6, since it is now possible to save the whole workspace.  

Click on the title bar of the ekma.pri window, one of the files you opened earlier, to make it the active window – the title bar becomes a more prominent colour for the active window.  Pre-treat the data by a square root transformation. With the transformed matrix as the active sheet, select Analyse>Resemblance and take the defaults of (Analyse between(Samples) & (Measure(Bray-Curtis similarity).  This creates a triangular matrix of similarities between every pair of samples, in a new window, which now becomes the active sheet for several further analyses.  (There are a wide range of other resemblance coefficients that can be accessed via the (More button and tab.  The measures that appear in the general reference book of Legendre P & Legendre L, 1998, Numerical ecology, 2nd English ed, Elsevier, are numbered in the same way as there.) 


When a resemblance matrix is the active window, the Analyse menu switches to display only the analyses which work with resemblances (e.g. Analyse>CLUSTER or >MDS).  Running routines on the Analyse menu produces graphical output, results windows and/or further worksheets.  The properties of plots can be amended through the Graph menu.  You can also get the graph menu items by right clicking the mouse when the cursor is over the graphics window.  Plots can be saved in PRIMER format (.ppl) but more usefully in several export forms, either pixel-based (.bmp, .jpg, .png, .tif) or vector-based Windows metafiles (.emf) for further manupulation in Powerpoint etc. 

Generate a dendrogram for a cluster analysis using the Bray-Curtis similarity matrix just produced.  With this as the active window, take Analyse>CLUSTER>Main>Cluster mode(Group average, and the (Plot dendrogram check box ticked (but not the SIMPROF box, for now).  Click on the OK button to produce the plot.  Try altering the plot’s appearance.  Click on a horizontal line to rotate parts of the dendrogram, as if it were a ‘mobile’ (demonstrating the relative arbitrariness of the x axis ordering), and click on a vertical line to collapse the tree below that point.  Reinstate by clicking again.  Add symbols to the x axis, representing the four pre-defined distance groups for samples from the oilfield, by Graph>Data labels & symbols>(Symbols:(Plot>(By factor>Dist ) & (Labels: (Plot).  Experiment with other options, e.g. changing title sizes and fonts on the Titles tab, unchecking the Plot history box on the General tab, Orientation(Right on Graph>Special etc.


By now, you have created many open windows and may be finding it hard to see the one of interest by shuffling the windows around.  This is more easily done by clearing the PRIMER desktop with Window>Close All Windows (this does not remove the files from the workspace, unlike the operation of v5), and then using the Explorer tree on the left of the desktop to identify the plots, results, worksheets etc that you want to view (click on their name).  You can rename any of these items by File>Rename… or, when the cursor is over a name on the Explorer tree then right clicking on the mouse gives you Save, Rename or Delete options (the latter also removes from the workspace all items that branch down from the deleted one).  The branching structure is not just for display – PRIMER 6 uses it heavily to suggest sensible defaults and to pass information, such as newly-created factors, down the tree to use in graphs, or even up the tree to the original data!

Workspaces can be saved in their entirety.  Do this for the current workspace with File>Save Workspace As>(File name: Test1); workspace files have extension .pwk and a different icon to data, resemblance or graph files. Now File>Close Workspace then re-open it again with File> Open>File name: Test1.pwk.  It re-appears exactly as it was saved (it has no dynamic links to files outside the workspace, so subsequent deleting/editing of these will not change the workspace data).


Sometimes you may wish to omit certain species or select only a subset of samples for analysis.  You can apply selection to one or both of samples and variables by first highlighing the rows and/ or columns, by clicking (and dragging) on the row or column labels.  These operations are toggled, so are cancelled by a simple repeat.  (A useful trick is to click in the blank box in the top left corner of the worksheet, which toggles between highlighting all and highlighting none.)  With the correct subset highlighted (the darkest shaded areas), choose Select>Highlighted.  The selected subset is displayed and analysis operates only on this subset.  Revert later to the full worksheet by Select> All and you can Edit>Clear Highlight (another useful trick is Edit>Invert Highlight and Select> Highlighted again, to get the complementary set of variables/samples to the one you had originally selected). Note that if you use this method of selection you must remember that highlighting alone is not selection: you must first highlight then select the highlights. Alternatively, select samples (or variables) by their numbers (e.g. Select>Samples>(Sample numbers: 1-5,11-15) or by levels of a factor (e.g. Select>Samples>(Factor levels>Factor name: Dist>Levels>Include: D).  

Any selection is only temporary – the selected portion is displayed but all the original data and factors are still there, in the background.  Saving the current sheet to a file will save the full data (this is to stop you overwriting your full data with a subset, by mistake).  To save only the selected portion to a file, you must first copy it to a new sheet, with Tools>Duplicate.  Only the selected portion is duplicated.  This is also the way you can do crossed selections using factor levels, e.g. select a subset of the sites, duplicate this sheet, then select a subset of times on the duplicated sheet. 


Duplicate is just one of several routines to manipulate your data or resemblance worksheets prior to (or between) analyses, using the Tools menu. When the active matrix is sample data the other choices cover: Aggregate, which uses a different form of worksheet, an aggregation file (defining which species belong to which genera, which families etc) to pool species counts, for example, to higher taxonomic levels; Average and Sum, which are most commonly used to average or total samples with the same factor level (e.g. average assemblages for each site, across all times); Check, which identifies potentially problematic data entries for some analysis choices (samples which are all zero, non-unique sample names, missing values, negative values etc); Merge, a comprehensive joining tool, which will combine two worksheets into one, using the sample and variable labels to identify how the join is made (e.g. two arrays of different samples but only partially overlapping species sets can be merged into a unified matrix – consistent spelling of labels is important here!); Missing, which provides ‘best predictions’ of isolated missing values – maximum likelihood estimates from the EM algorithm – under strict model conditions (use with great care!); and Rank variables, which can be a useful alternative, for placing environmental-type data on a common measurement scale, to normalisation after Transform (individual) operations are carried out.  This individual transform option greatly expands the limited range of overall transforms on the Analyse>Pre-treatment>Transform (overall) menu.  The latter are applied in the same way to all data in the sheet, but the individual transforms apply only to all values (V) in a highlighted set of variables, and the user may build a specialised transform expression, using scientific functions, operators, other variables etc.  Finally, Transpose switches rows and columns for the purpose of exporting to another application (note: this is not the same thing as changing the designation of which labels represent samples and which variables, via Edit>Properties).  The output of Tools are usually new worksheets, which become the input to an Analyse option.

Some of the same menu items e.g. Duplicate, Transform, appear under the Tools menu when the active sheet is a resemblance matrix, but others are specific to resemblances, e.g. Dissimilarity converts similarities to dissimilarities (and vice-versa), by subtracting from 100.  This is really only needed for exporting to other applications since internally PRIMER knows which matrices are of which type (similarity, dissimilarity or distance).  It will automatically match them in the right way, e.g. if you try to correlate a biological Bray-Curtis similarity matrix to an environmental Euclidean distance matrix (using Analyse>RELATE), low distances will be matched to high similarities.  

Nearly all choices from the Tools or Analyse menu will produce text-format results.  These are separate windows, denoted by notepad icons in the Explorer tree.  It is thus easy to find and display the results from any particular analysis (the v5 single large log of all results no longer exists, its purpose being more helpfully taken by the Explorer tree).  Individual results windows can be saved to .rtf or .txt format files but, more simply, the usual Windows Edit>Copy (Ctrl+C) works on text in the results window that has been highlighted, e.g. it can easily be pasted to a Word file.  When results tables are pasted into Excel in this way the entries are placed into a grid automatically.  In Word files, they can be converted from text to tables simply by specifying tab as the separator.

With the Bray-Curtis resemblance matrix from the Ekofisk data as the active sheet, run the one-way ANOSIM test on the four groups of samples at different distances from the oilfield (the factor Dist), by Analyse>ANOSIM>General>(Design(One way>Factor A: Dist) & (Max permutations: 999) & ((Pairwise tests for worksheet) & ((Plot histogram).  Three new windows are created.  Firstly, the results window gives the ANOSIM R statistic (see Methods manual, Chapter 6) for testing whether assemblage structure varies across the four distance groups, and shows that it does. The graph displays the histogram of the null (permutation) distribution of R, and shows why the null hypothesis of ‘no difference in assemblage structure between groups’ is decisively rejected (the observed R is well outside the null distribution).  The results window then gives the pairwise tests between pairs of groups.  The values of ANOSIM R for each pair have also been sent to a further triangular worksheet (where they could, for example, be saved to Excel or even, in more complicated cases, be used as input to a further analysis).

 

Much of the above is preparatory to the core routines in PRIMER, found on the Analyse menu, whose operation is covered in detail in the following chapters, and its rationale in the associated Methods manual.  All that can be given here is a brief list.  When the active window is a sample data sheet, the choices include: BEST, selecting variable subsets in one matrix which best match the multivariate pattern of samples in a different matrix, e.g. ‘explaining’ biological assemblage structure with a subset of environmental variables; LINKTREE, a non-parametric multivariate form of ‘classification and regression trees’, tackling the same problem as BEST but in a more piecemeal way, e.g. trying to identify which individual abiotic variables, and what ranges of their values, appear to be responsible for discriminating different assemblage groupings; DIVERSE, calculating a wide range of standard diversity measures, including some newer ones based on the concept of taxonomic or phylogenetic breadth of an assemblage; PCA, ordination by Principal Components, more useful for physical/chemical/ecotoxicological and similar abiotic data than for species abundances; SIMPER ‘similarity percentages’, identifying variables (e.g. species) that primarily account for Bray-Curtis dissimilarities or Euclidean distances observed between groups of samples; SIMPROF, ‘similarity profiles’, which test for significant evidence of structure among samples that have no pre-defined grouping (this can be combined with both LINKTREE and CLUSTER to justify identification and interpretation of clusters); Draftsman Plot, a multiple scatter plot of pairs of variables (often environmental); Dominance Plot and DOMDIS, producing and testing groups of dominance curves and ABC plots, which are graphical forms of diversity measures on species abundance (and biomass), as is a Geometric Class Plot.  Finally, a Species-Accum Plot will graph species-accumulation curves, showing how the observed number of species increases as new samples are added, and also plotting a wide range of species richness estimators (the asymptote of species-area curves, assuming ‘closed’ communities).  Some of these routines (e.g. BEST or ABC curves) require two or more input worksheets:  one is always identified as the active window before the routine is run (e.g. the environmental matrix that will be selected from in BEST, or the abundance matrix for ABC curves) and the other is supplied to the routine via a dialog box (e.g. the community similarity matrix in BEST, or the biomass sheet in ABC curves). 
When the active window is a resemblance matrix, the Analyse menu covers (as well as CLUSTER and ANOSIM already met): MDS ordination plots, non-metric multidimensional scaling, which is central to the PRIMER approach; MVDISP, which compares multivariate dispersion across groups; RELATE, covering non-parametric Mantel-type tests between resemblance matrices; and 2STAGE, a second-stage analysis (an MDS of MDS’s!), useful for comparing the effects of different choices of data aggregation, transformation, resemblance etc.  One routine, TAXDTEST, is accessed through the Analyse menu when an aggregation matrix is the active window: this tests biodiversity measures based on taxonomic distinctness for departures from ‘expectation’. 
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